
Willkommen!

Vielen Dank, dass sie sich für unsere Relais-Abschirmung für den D1 Mini

von AZ-Delivery entschieden haben. In den nachfolgenden Seiten werden wir

Ihnen erklären wie Sie das Gerät einrichten und nutzen können.

Viel Spaß!
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Einführung

Relais  werden  zur  Steuerung  von  "AC"  -  Stromkreisen  verwendet  und

schalten  diese  EIN  oder  AUS.  Das  Relais  ist  eines  der  wichtigsten

Steuerelemente.  Es  ist  ein  elektrischer  Schalter,  der  auf  ein  vom

Mikrocontroller  empfangenes  Signal  reagiert  (wie  bei  Arduino  oder

Raspberry  Pi).  Relais  werden  häufig  in  der  Fernsteuerung,  in  der

Kommunikation,  in  mechatronischen  Geräten,  in  leistungselektronischen

Geräten  usw.  verwendet.  Sie  können  auch  verwendet  werden,  um

leistungsstarke Spannungs-/Strom-Elektronik (wie "AC"- oder "DC"-Motoren

oder jedes "AC"-Gerät usw.) von der Mikroelektronik (wie Mikrocontroller,

Sensoren usw.) zu trennen.

Im Inneren des Relais befindet sich ein mechanischer Schalter (drei gelbe

Metallstäbe, von denen einer in der Mitte zur Seite gebogen und beweglich

ist), der durch das zweite Element des Elektromagneten (gelber Zylinder)

gesteuert wird, wie auf dem Bild unten dargestellt:
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Im nicht aktiven Zustand befindet sich der Schalter im AUS-Zustand, der

"NC"-Pin ist mit dem gemeinsamen (common) Pin verbunden und "NO" ist

nicht verbunden. Wenn der Strom an den Elektromagneten angeschlossen

wird  (über  Transistor  und  Gleichrichterdiode),  wird  der  Schalter  in  den

aktiven  Zustand  versetzt,  wodurch  der  common  Pin  mit  dem  "NO"-Pin

verbunden wird.

Das Relais-Abschirmungsmodul besteht aus einem Relais, das bis zu 10A

250V AC  und  10A 30V DC  verarbeiten  kann,  einer  LED,  zwei

Widerständen, einem NPN-Transistor und einer Gleichrichterdiode.

Auf der DC-Seite des Boards befinden sich zwei Reihen von 8 Pins für den

Anschluss an das D1 Mini-Board. Die Abschirmung verwendet einen 3,3V-

Pin, einen GND-Pin und einen Digital-E/A-Pin  5 (mit  D1 bezeichnet, dies

wird später im Text näher erklärt). Um den Zustand des Relais zu ändern,

ändern Sie den Zustand vom Digital-E/A-Pin  5.  Auf  der AC-Seite gibt es

eine  dreipolige  Schraubklemmenleiste,  auf  der  die  Pins  folgendermaßen

bezeichnet werden: Normalerweise geschlossen – NC-Pin, Gemeinsamer

Pin und Normalerweise offen - NO-Pin. 
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Einführung in den  ESP8266 und das D1 Mini Modu

Das ESP8266-Modul  ist  ein  "System on a  Chip"  (SoC).  Es besteht  aus

einem Tensilica L106 32-Bit-Mikrocontroller und einem Wifi-Transceiver. Es

hat  11  GPIO-Pins  (General  Purpose  Input/Output)  und  einen  analogen

Eingang.  Das  bedeutet,  dass  Sie  ihn  wie  jeden  Arduino  oder  anderen

Mikrocontroller  programmieren können. Das Beste an dem ESP8266 ist,

dass Sie mit ihm über Wifi kommunizieren können, so dass Sie mit ihm eine

Verbindung  zu  Ihrem  Wifi-Netzwerk  herstellen,  sich  mit  dem  Internet

verbinden,  einen  Webserver  mit  echten  Webseiten  hosten  und  Ihr

Smartphone  mit  ihm  verbinden  können,  usw.  Er  unterstützt

Netzwerkprotokolle, wie Wi-Fi, TCP, UDP, HTTP, DNS, etc. 

Das AZ-Delivery D1 Mini-Modul ist  ein Entwicklungs-Board, das auf dem

ESP8266-Chip  basiert.  Es  hat  11  digitale  Ein-/Ausgangspins  und  einen

analogen  E-Pin.  Alle  digitalen  E/A-Pins  sind  durch  Software  Interrupt-,

PWM-,  I2C-  und  1-Draht-fähig.  Die  analoge  Eingangsspannung  liegt

zwischen 0V und 3,3V DC. Das Modul verwendet einen microUSB-Port und

den CH340G-Chip  mit  einer  Programmierschaltung zur  Programmierung.

Außerdem fungiert der microUSB-Port als Stromversorgung für das Modul. 

Es gibt verschiedene Möglichkeiten, das D1-Mini-Modul zu programmieren.

Wenn Sie bereits mit Arduino-Boards zu tun hatten, dann wird das einfach.

Das  ist  allerdings  nicht  die  einzige  Möglichkeit.  Es  gibt  weitere

Möglichkeiten, das D1-Minimodul zu programmieren (offizielles ESP SDK

für  C-Programmierung,  Lua-Interpreter,  MicroPython-Firmware,  sind  nur

einige von vielen). 

- 5 -



Der D1 Mini ist ein Breakout Board für den ESP8266 Mikrocontroller. Dieses

Board hat einen CH340 USB zu Serial-Chip, der zur Programmierung des

ESP8266-Mikrocontrollers verwendet wird.

Technische Daten des D1 Mini Moduls

Mikrocontroller: ESP8266

Betriebsspannung: 3.3V

Digitale E/A-Pins: 11, all support interrupt/pwm/I2C/1-wire (except D0)

Analoge Eingangspins: 1 (Max input: 3.2V)

Taktfrequenz: 80MHz/160MHz

Flash-Speicher: 4MB

USB-Anschluss: Micro USB

Kompatibel: MicroPython, Arduino IDE, NodeMCU 
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Technische Daten der Relais-Abschirmung

» TTL-Kontrollsignal: 3.3V bis 12V DC

» Maximum AC: 10A 250V

» Maximum DC: 10A 30V

» Kontaktart: Beide: Normalerweise geschlossen – NC, 

Normalerweise offen - NO

» Dimensionen: 28 x 28 x 18mm [1.1 x 1.1 x 0.71in]
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Pinbelegung

Die Pinbelegung ist wie folgt:

Der Pin GPIO5 ist der Pin, an dem der Relaiseingang angeschlossen ist.

Wenn der Zustand des GPIO5 Pins geändert wird, kann der Zustand des

Relais geändert werden.
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Wie man die Arduino-IDE einrichtet

Falls die Arduino-IDE nicht installiert ist, folgen Sie dem link und laden Sie

die Installationsdatei für das Betriebssystem Ihrer Wahl herunter.

Für  Windows Benutzer:  Doppelklicken  Sie  auf  die  heruntergeladene

.exel-Datei und folgen Sie den Anweisungen im Installationsfenster.
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Für Linux laden Sie die Datei mit der Erweiterung ".tar.xz" herunter, die

Sie dann extrahieren müssen. Wenn Sie sie extrahieren, gehen Sie in das

extrahierte Verzeichnis und öffnen Sie das Terminal in diesem Verzeichnis.

Sie  müssen  zwei  ".sh"-Skripte  ausführen,  das  erste  heißt  "arduino-

linux-setup.sh", das zweite "install.sh".

Um das erste Skript  im Terminal  auszuführen, führen Sie den folgenden

Befehl aus:

sh arduino-linux-setup.sh user_name

user_name -  ist  der  Name des  Superusers  im  Linux-Betriebssystem.

Danach  werden  Sie  aufgefordert,  das  Passwort  für  den  Superuser

einzugeben. Warten Sie einige Minuten, bis das Skript alles abgeschlossen

hat.

Nach der Installation des ersten Skripts führen Sie das zweite Skript mit

dem Namen "install.sh"  aus.  Führen Sie im Terminal  den folgenden

Befehl aus:

sh install.sh

Nach  der  Installation  dieser  Skripte,  gehen  Sie  zu  All Apps,  um  die

installierte Arduino IDE zu finden.
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Fast  alle  Betriebssysteme  werden  mit  einem  vorinstallierten  Texteditor

ausgeliefert  (z.B.  Windows mit  Notepad,  Linux  Ubuntu  mit  Gedit,

Linux Raspbian mit Leafpad usw.). Alle diese Texteditoren sind für den

Zweck des eBooks vollkommen in Ordnung.

Zunächst ist zu prüfen, ob Ihr PC ein Arduino-Board erkennen kann. Öffnen 

Sie die frisch installierte Arduino-IDE, und gehen Sie zu: 

Tools > Board > {your board name here} 

{your board name here} sollte der Arduino/Genuino Uno sein, wie

es auf dem folgenden Bild zu sehen kann:

Der Port, an den das Arduino-Board angeschlossen ist, muss ausgewählt

werden. Gehe zu: Tools > Port > {port name goes here} und

wenn  das  Arduino-Board  an  den  USB-Port  angeschlossen  ist,  ist  der

Portname im Drop-down Menü auf dem vorherigen Bild zu sehen. 
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Wenn  die  Arduino-IDE  unter  Windows  verwendet  wird,  lauten  die

Portnamen wie folgt:

Für Linux Benutzer, ist zum Beispiel der Portname /dev/ttyUSBx, wobei

x für eine ganze Zahl zwischen 0 und 9 steht.
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D1 Mini with Arduino IDE

Um  die  Arduino  IDE  so  einzurichten,  dass  der  D1  Mini  darüber

programmiert werden kann, folgen Sie ein paar einfachen Schritten. 

Als  erstes  müssen  Sie  den  ESP8266-Core  installieren.  Um  ihn  zu

installieren, öffnen Sie die Arduino IDE und gehen Sie zu:  

File > Preferences 

und finden Sie das Feld Additional URLs. 

Dann kopieren Sie folgende URL:

https://arduino.esp8266.com/stable/package_esp8266com_index.json

und fügen Sie ihn in das Feld Additional URLs ein. 
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Wenn Sie bereits einen oder mehrere Links in diesem Feld haben, fügen

Sie einfach ein Komma nach dem letzten Link ein, fügen Sie den neuen

Link  nach  dem  Komma  ein  und  klicken  Sie  auf  die  Schaltfläche  OK.

Schließen Sie dann die Arduino-IDE.

Öffnen Sie die Arduino IDE und gehen Sie zu: 

Tools > Board > Boards Manager 

Es öffnet sich ein neues Fenster, geben Sie "esp8266" in das Suchfeld ein

und installieren Sie das Board mit dem Namen "esp8266" von "ESP8266

Community", wie unten abgebildet:

Jetzt haben Sie den ESP8266-Core installiert.
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Als Nächstes wählen Sie das richtige Boar in der Arduino IDE aus. Öffnen

Sie die Arduino IDE und gehen Sie zu: 

Tools > Board > {board name}

und wählen Sie  das erste Generic ESP8266 Module aus,  wie unten

abgebildet:
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Wählen  Sie  danach  den  Port  aus,  an  dem der  D1  Mini  verbunden  ist.

Gehen Sie zu: Tools > Port > {port name goes here} 

Wenn  der  D1  Mini  über  den  USB-Port  verbunden  ist,  sollten  mehrere

Portnamen  verfügbar  sein. In  diesem  eBook  wird  die  Arduino  IDE in

Windows verwendet, die Portnamen lauten daher wie folgt:

Für  Linux-Benutzer  lautet  der  Portname “/dev/ttyUSBx”  zum Beispiel,

wobei "x" eine ganze Zahl zwischen 0 und 9 darstellt.
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Verbindung der AC-Seite des Relais

Zu diesem Zweck werden wir eine Glühbirne, ein zweiadriges Kabel und

einen Netzstecker verwenden. Der AC-Teil  des Anschlussschemas ist für

beide Relais auf dem 8-Relais-Modul gleich. Schließen Sie das Relais mit

der  Glühbirne  und  dem  Netzstecker  an,  wie  auf  dem  untenstehenden

Anschlussschema dargestellt: 

Modul Pin   > Netzstecker, Glühbirne

Common Pin > Eine Seite d. Netzsteckers Roter Draht

Normally opened Pin > Eine Seite d. Netzsteckers Roter Draht

Glühbirne   > Netzstecker

And. Seite d. Glühbirne   > And. Seite des Steckers Schwarzer Draht
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Löten

Sowohl  die  Relais-Abschirmung als  auch  der  D1 Mini  werden ungelötet

geliefert.

Der D1 Mini wird mit drei verschiedenen Sätzen von Stiftleisten geliefert,

zwei weibliche Stiftleisten mit acht Stiften, zwei männliche Stiftleisten mit

acht  Stiften  und  zwei  weibliche  Stiftleisten  mit  langen  Beinen  mit  acht

Stiften.

Die Relais-Abschirmung wird mit zwei achtpoligen Steckerleisten geliefert.

Um die Relais-Abschirmung mit dem D1-Mini-Modul zu verbinden, müssen

zunächst die Steckerleisten jeder Platine auf  das jeweilige Board gelötet

werden. 

Löten Sie Sie zuerst dieBuchsenleisten mit langen Beinen auf das Board

des D1-Minimoduls, wie unten abgebildet:
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Als  nächstes  löten  Sie  die  männlichen  Stiftleisten  an  die  Relais-

Abschirmung, wie unten abgebildet:
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Verbindung der Relais-Abschirmung mit dem D1 Mini

Verbinden Sie die Relais-Abschirumung mit dem D1 Mini Modul, wie unten

abgebildet:
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Sketch-Beispiel

#define RELAY_PIN 5

void setup() {

  pinMode(RELAY_PIN, OUTPUT);

}

void loop() {

  digitalWrite(RELAY_PIN, HIGH);   

  delay(1000);               

  digitalWrite(RELAY_PIN, LOW);   

  delay(1000);                 

}

Laden Sie  den  Sketch  auf  den  D1 Mini.  Sie  werden Klicks  vom Relais

hören.  Jedes  Mal,  wenn  das  Relais  den  Zustand  wechselt  (aktiv  zum

Ruhemodus und vice versa) kann man Klicks hören.

Die Glühbirne sollte mit einem Intervall von einer Sekunde blinken.
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Ändern Sie die Status der NO/NC Pins mit der folgenden Codezeile:

digitalWrite(RELAY_PIN, HIGH)

- NC Pin ist nicht mit dem gemeinsamen Pin (common pin) verbunden

- NO Pin ist mit dem gemeinsamen Pin (common pin) verbunden

digitalWrite(RELAY_PIN, LOW)

- NC Pin ist mit dem gemeinsamen Pin (common pin) verbunden

- NO Pin ist nicht mit dem gemeinsamen Pin (common pin) verbunden

Sie haben es geschafft. Sie können jetzt unser

Modul für Ihre Projekte nutzen.
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Jetzt sind Sie dran! Entwickeln Sie Ihre eigenen Projekte und Smart- Home

Installationen.  Wie  Sie  das  bewerkstelligen  können,  zeigen  wir  Ihnen

unkompliziert  und  verständlich  auf  unserem Blog.  Dort  bieten  wir  Ihnen

Beispielskripte  und  Tutorials  mit  interessanten  kleinen  Projekten  an,  um

schnell in die Welt der Mikroelektronik einzusteigen. Zusätzlich bietet Ihnen

auch  das  Internet  unzählige  Möglichkeiten,  um  sich  in  Sachen

Mikroelektronik weiterzubilden.

Falls  Sie  nach  weiteren  hochwertigen  Produkten  für  Arduino  und

Raspberry  Pi  suchen,  sind Sie  bei  der  AZ-Delivery  Vertriebs GmbH

goldrichtig.  Wir  bieten  Ihnen  zahlreiche  Anwendungsbeispiele,

ausführliche  Installationsanleitungen,  Ebooks,  Bibliotheken  und

natürlich die Unterstützung unserer technischen Experten.

https://az-delivery.de

Viel Spaß!

Impressum

https://az-delivery.de/pages/about-us
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